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WORD PROCESSING. 

Word processing is the process of creating, saving, editing, formatting and 

printing text and graphics documents using an electronic word processor 

An electronic word processor is an application software that enables the user 

to create, edit, format and print text and graphics documents.  

 

Examples of common word processors include 
 Microsoft word, Corel Word Perfect, Lotus Word Pro, Apple Works and 

OpenOffice.org Writer, La Tex editor, Abi Word, LyX, Word pad, Word 

star e.t.c 

 

POPULAR FEATURES OF WORD PROCESSING SOFTWARE 

 Word wrap. This allows a user to type continuously without pressing 

the enter key at the end of each line.  

 Replace. This allows the user to substitute existing characters, words 

or phrases with new ones.  

 Spell checker. This allows a user to check the spelling of a whole 

document at one time or to check and even correct the spelling of 

individual words as they are typed (i.e auto correct)  

 Grammar checker. Reports grammatical errors and suggests way to 

correct them.  

 Thesaurus. This suggests alternative words with the same meaning 

(synonyms) for use in the document.  

  Mail merge. This creates form letters, mail labels and envelopes. 

Used when similar letters have to be sent to several people. The 

names and addresses of each person can be merged with one single 

standard document and then printed out.  

 Automatic page numbering numbers the pages automatically in a 

document  

 Tables allow the user to organize information into rows and columns.  

 Clip Art gallery allows a user to insert drawing s, diagrams and 

photographs into a document.  

 Mathematical formulae typesetting. This allows a user to typeset 

complex mathematical formulae within the program.  

 Multi-columns. This arranges text in two or more columns that look 

like or similar to newspaper columns or magazines. 

 Macros: A macro is a character of words that represents a series of 

key strokes. The key strokes can represent text or commands. 

 WYSIWYG (What You See Is What You Get): Here a document 

appears on the display screen exactly as it will be printed. 
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Advantages of electronic word processor 

 A document can be stored for future use  

 Typing using a word processor is easier and more efficient due to 

automated features such as word wrap, autotext and autocomplete 

 Most word processors have superior editing tools such as thesaurus, 

autocorrect, spelling and grammar checker. 

 Documents can normally be previewed before printing 

 Word processors have superior formatting features like underlining, 

boldfacing, applying different colors etc 

 It’s possible to print multiple copies once 

 Has the ability to create and import tables, text and graphics from 

other programs  

 It provides predefined features for generating headers, footers, 

indexes, footnotes and references 

 Convenient to create form letters and mailing labels 

Purpose of word processing 

Mostly, word processors are used for writing; Letters, Reports, Projects, 

Books, Essays, Memos, Curriculum vitae etc 

Choosing a word processor 

The choice of a word processor depends on the following factors: 

 The type of operating system for example, most microcomputers are 

currently running on windows based operating system such as 

Microsoft windows meaning you should consider acquiring a GUI 

based word processors 

 Its user-friendliness, i.e. ease of use 

 Its formatting and editing features should be good and varied 

Starting Microsoft Word 

 Click on the start menu and point to Programs/ All programs 

 Point to Microsoft Office 2003 then click Microsoft Office Word 

2003 

Microsoft Word screen layout 

1. Title bar. This is blue in color and it contains the name of the 

program one is currently running. It usually contains minimize, 

maximize, restore and close buttons. 

2. Menu bar. This is located below the title bar and contains words 

which help the user to format the text as required. It contains menus 
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like File, view which have sub-menus that can be used to perform 

given tasks like save, save as, print e.t.c 

3. Standard toolbar. This contains icons that act as short cuts to 

different tasks. These icons can be used to carry out common tasks 

such as launching a new document window, opening a file, saving, 

spelling and grammar checking. 

4. Formatting toolbar. Formatting toolbar is used to make a document 

more appealing ie. It contains features that change the appearance of 

text. E.g B(bold), U(Underline), I(italics) e.t.c 

5. Rulers. Microsoft Word provides the user with vertical and horizontal 

on screen rulers that help the user set tabs and indents as well as 

position text and objects. If the Ruler isn’t visible, then display it 

using the following procedures: 

 Click the View menu option 

 On the drop down menu that appears, Click ruler, a check marker or 

tick will appear next to it showing that the ruler is displayed on the 

screen 

6. The drawing tool bar: This has features that can be used to draw 

various shapes 

7. Status bar. This is found at the button of the screen and it acts as a 

Common action link between the user and the program. .It contains 

features like the exact page of the cursor i.e page 1,sec1, col 1 e.t.c 

8. Task bar. This is at the bottom of the window and blue in color and it 

contains the start button and shows all open programs. 

9. Scroll bars: These are both horizontal and vertical bars that enable 

you to either navigate the document on the window either Vertically 

(upwards or downwards) or Horizontally (left or right). 

10. Task Pane. Once you launch word 2003, a task pane is automatically 

displayed docked on right of the window. This pane contains shortcuts 

to commonly performed tasks such as the recently opened documents. 

You can close the task pane by clicking the close button on its top 

right corner. 
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Note: 

Toolbars 

These are rows of buttons or icons that represent commands. The command 

buttons are shortcuts to the same commands you can access from the menu 

bar. There are various toolbars available in Microsoft Word but the most 

common are the standard and formatting toolbars 

Hiding and displaying the toolbars: 

 Click the View menu option 

 Position the pointer on Toolbars 

 Click the type of toolbar required to select it 

Creating a document based on template 

 Click File menu then New 

 On the task pane displayed on the right, under Template, click on My 

Computer 

 On the template dialog box, click on the tab that contains a template 

you wish to use 

 Select a template from templates window 

 Replace the general content with your own content 

Saving a document 

 On the File menu, click Save as. Alternatively press Ctrl + S or click 

the save button on the standard toolbar. Save dialog box is displayed. 

 In the File name box, type a unique name for the documents 

 Select a location or drive you want to save in by clicking the down 

arrow on the right of save in list box 

 Click save button  

Protecting a document with a password 

A password is a combination of characters that prevents other users from 

opening and changing a document without permission. To save a document 

with a password: 

 Create or open the document you want to protect 

 On the File menu, choose Save As 

 Click the down arrow on the Tools button in the save as  dialog box 

 Click Security options 

 Type in a password in the password to open . This prompts the user to 

enter password when opening a document. 
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 To protect against modification, type in a password in the password to 

modify text box, and then click OK 

Note: A password is case sensitive always note the combinations of 

characters used 

 

Closing the current document. 

 Closing means unloading the current active document from the memory so 

that the user can create or open another without necessarily exiting from 

Word.  To close a document: 

 On the File menu, click Close. Alternatively press Ctrl + F4  

 Save document changes if prompted 

Opening an existing document 

 On the File menu, click Open command or on the standard toolbar, 

click the open button. Alternatively press Ctrl + O key combinations 

on the keyboard. The open dialog box appears. 

 Select a drive or folder where the file is saved 

 In the File menu box, type or select the name of the document you 

want to open 

 Click the open button 

Exiting from word 

 To exit from Word, save changes to your document  

 On the File menu, click Exit. Alternatively press Ctrl + F4 

EDITING WORD DOCUMENTS 

Editing refers to making necessary changes to an existing document. 

Editing modes 

There are two editing modes in a word processors that assist the user in 

editing individual characters in a text document. These are: 

Insert mode 

This is a default mode in most word processors. In this case when text is 

inserted between words and characters, it pushes the existing text to the right 

as you type. 

Type over mode 

In type over mode, when text is typed between existing words or characters, 

the new text automatically replaces the character on the right of the insertion 

pointer as you type.  

Deleting text 

To delete a character or a word from the right to the left: 

 Place the insertion pointer on the right of the word 
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 Press the backspace key  

 

To delete a character to the right of the cursor position: 

 Place the insertion pointer on the left of the word 

 Place the Delete key 

To delete a block of text: 

 Highlight the text to be deleted 

 Press the Delete/Del key 

Restoring deleted text 

 Click the Edit menu, then the Undo command. Alternatively press Ctrl 

+ Z 

Copying and moving text and objects 

Copying means creating a duplicate of text or an object, Moving means 

changing the position of the text or an object in a document. 

To copy a block of text: 

 Highlight the text 

 Click Edit menu, then Copy command or simply click the Copy 

button on the standard tools bar  

 Position the insertion pointer where you want to copy the text 

 Click Edit menu then paste or simply click the paste button on the 

standard toolbar 

NB: To use the keyboard shortcut keys, press Ctrl + C to copy, then Ctrl + V 

to paste 

To move text and objects: 

  Highlight the text 

 Click Edit, then Cut or simply click the Cut button from the standard 

toolbar 

 Position the insertion pointer where you want the text to be placed  

 Click Edit, then Paste or click the Paste button on the standard toolbar  

NB: To use the keyboard shortcut key, press Ctrl + X to cut, then Ctrl + V to 

paste 

Find and Replace 

To find and replace a word or phrase:  

On the Edit menu, click Find or Replace. Click the Replace tab 

In the Find What box, type the word or phrase to find 
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In the “Replace with” box, type the word or phrase to replace the target word 

or phrase 

Use the button Replace, Replace All or Find next to navigate through the 

search replace process 

NB: You can use the keyboard shortcut Ctrl + F to find 

Proofreading 

This refers to checking whether the document has typographical and 

grammatical errors. Microsoft Word has proofing tools such as Spelling and 

grammar checker and Autocorrect. 

Spelling and grammar checker 

The spelling and grammar checker is an in built tool that helps the user to 

correct spelling errors and incorrect grammar structures. To check the 

accuracy of spelling and grammar: 

Click Tools menu option 

 Click Spelling and grammar on the drop down menu. The spelling and 

grammar checker dialog box appears 

 Words that do not match in the custom dictionary are highlighted for 

correction. The lower plane of the dialog box suggests to the user a 

list of suggested correct words. 

Either choose one of the following buttons: 

 Click Change to correct only the highlighted incorrect word 

 Click Change All to correct all the occurrences of the misspelled word 

 Click Ignore to retain the highlighted and continue 

 Click Ignore All to retain all the occurrences of the same word or 

phrase in the document from another language e.g. Kiswahili 

 Click Add to add the word to the custom dictionary 

Autocorrect  

This automatically detects wrongly spelled or capitalized word and replaces 

them with the correct word. To turn autocorrect on or off: 

 Click Tools menu, then Autocorrect Options 

 To turn on autocorrection, select the “Replace text as you type”. 

 In the Replace box, type the commonly misspelled word 

In the Withbox, type the correct spelling for the word 

 Click OK to close the dialog box 

Using the thesaurus 

This is an editing tool that helps the user find words or phrases with similar 

meaning (synonyms) or opposite meaning (antonyms) to the one selected. 

To use the thesaurus: 
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 Select a word or phrase 

 Click Tools, then point to Languages 

 Click Thesaurus to display Task pane 

 Choose an alternative word or phrase you intend to use as replacement 

for the selected text 

 To replace a word or a phrase with an antonym, select the word or 

phrase enclosed in  brackets 

 From drop down list, click Insert. 

FORMATTING WORD DOCUMENT. 

Formatting refers to enhancing the appearance of a document. You can text, 

paragraphs, pages or the entire document.  

Formatting text attributes 

To format existing text using the format menu: 

 Highlight the text to be formatted 

 On the Format menu, click the Font command, a dialog box with all 

text formatting features is displayed. 

 To change font type and size, where necessary scroll down the Font 

list box and select a font type. To increase the font size, where 

necessary, scroll down the Size list box and select the required size. 

 Bolding text: Bolding makes the selected text appear darker than the 

rest of the text. To bold text: 

a) Activate the font dialog box 

b) From the font dialog box, select Bold 

 Underline text: Underlining refers to placing a line at the base or 

bottom of a word or phrase. To underline: 

a) Activate the font dialog box 

b) Click the down arrow on the right of underline and select the 

underline style required e.g. single, double, dashed  e.t.c 

 Italicizing text:  To italicize is to make the text slant forward 

a) To italicize, activate the font dialog box 

b) Under font style, Click Italic 

 Changing the font color: In most cases, the font default color is black. 

However you can change the font color for example to red, green, 

blue e.t.c. To change font color: 

a) Activate the font dialog box 

b) Click the down arrow at the right of font color list box and select the 

color of your choice. 
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Using the formatting toolbar 

This lets the user easily format text by clicking the required button. 

Change case 

When typing text there are a number of cases the user may intend to 

apply in order to create contrast within the text. These are: 

1. Sentence case: All first characters in a sentence are in upper case 

(capitalized) 

2. Lower case: All characters appear in lower case 

3. Upper case: All characters appear in Upper case 

4. Title case: All the first characters  of each word in a sentence 

appear in upper case 

5. Toggle case: It changes upper case to lower case and vice versa 

To change case of an existing text: 

 Highlight the text 

 On the Format menu, click Change case 

 In the change case dialog box, select the case type to be applied 

 Click OK. 

Superscript and Subscript 

A superscript appears just below the rest of the characters like in cm2 

while a subscript appears just below other characters as in H2O. 

To make text superscript or subscript: 

 Highlight the character(S) 

 On the Format menu, click Font 

 On the Font dialog box select Superscript or Subscript 

Drop cap 
A drop cap is a large initial letter either at the beginning of a sentence or 

paragraph. 

To apply a drop cap: 

 Highlight the first character of a sentence 

 Click on the Format menu, and then select Drop cap. Drop cap 

dialogue box appears 

 Click Dropped or In margin 

 Select font in case you wish to apply in a certain font in a dropped cap 

  Specify the number of lines to drop and then click OK 

Indenting paragraphs        

Indenta tion refers to moving the text away from margin. You can 

indent the first sentence in a paragraph [first line indent], the whole 
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paragraph [full indent] or the rest of the text except the first line indent 

[hanging indents]. To indent; 

 Select the paragraph to be indented. 

 On the Format menu, click Paragraph. Paragraph properties dialog 

box appears 

 Click the down arrow in the list box under special and select the type 

of indentation you need e.g. hanging, first line etc. 

 Specify how far the paragraph is to be indented from the margin in 

“By” text box. 

 Click OK to apply the indent and close the dialog box. 

Line spacing  

This refers to the vertical distance between lines of text. The default line 

spacing is single spacing. To change line spacing: 

 Highlight the text, 

 On the Format menu, click Paragraph, 

 Click the down arrow from the Line spacing list box and select the 

spacing required e.g. double 1.5, etc 

 Click OK to effect the changes 

Bullets and numbering 

Bullets and numbers are used to create ordered lists. To add bullets or 

numbers, 

 Highlight the text,                                                                       

 Click on the Format menu, and then click Bullets and Numbering. 

Dialogue box for bullets and numbering appears. 

 Click on Bulleted, Numbered or Outline Numbered tab 

 Select the type of bullets or numbering, then click OK 

Page and document formatting  

This refers to the formatting of individual pages or the entire document. 

These include; subdividing a page into columns, page set up, page 

numbering, inserting headers and footers, inserting footnotes end notes etc. 

 

Columns 

Columns subdivide a page into several vertical sections. To set columns: 

 Highlight the paragraph 

 On the Format menu, click Columns. 

 In the columns dialogue box, enter the number of columns, Set the 

columns width then click OK 

Setting columns and section breaks  

Column and section breaks are used to force the insertion pointer to move to 

a new column or section in a page. This allows the user to apply more than 

one format to the same document. To insert a column or section break: 
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 Position the text to cursor in the document where you want the break 

to be inserted. 

 Click Insert menu then Break. 

 From the Breaks dialogue box, select the type of break to insert and 

then click OK 

 

Entire document set up. 

 

Page set up options let the user specify the size of the margins, paper size 

and layout. 

To set up a page: 

 On the Format menu, click Page setup. 

 In the Page setup dialogue box click either of the following:                                                                              

 Margins tab to setup page margins. 

 Paper tab to specify paper type and orientation. 

 Layout to specify the page content layout relative to margins. 

 Click OK 

Setting page margins 

Page margins are blank spaces around the edges of the page. To set up 

margins: 

 On the File menu, click Page setup. A page setup dialogue box 

appears. 

 Click the margins tab. 

 Enter the values for left, right, top and bottom margins in the 

respective boxes. 

 Click OK 

Specifying page orientation. 

Page orientation refers to the position of the page in relation to the text. 

There are 2 available orientations and these are: 

Portrait: Here the text and graphics are printed with the longest side placed 

vertically e.g. on A4 piece of paper. 

Landscape: With landscape the text and graphics are placed horizontally. 

To select page orientation: 

On the Format menu, choose Page setup. 

Click on Paper size tab on the page setup dialogue box. 

Select the orientation required and then click on o.k. button 

 

Inserting headers and footers 
Headers are lines of text that appear at the top margin of every page or 

selected pages in a document while Footers are lines of text that appear at 

the bottom margin. 

To insert a header and footer: 
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 On the View menu, click Headers and Footers. 

 To create a header, enter text or graphical object in the header area. 

 To create footer, click inside footer area and enter the text or graphical 

object. 

 Click Close on the header footer toolbar. 

Inserting page numbers 
Page numbers are used to organize a large document for ease of reference. 

To insert a page number: 

 On the Insert menu, click Page Numbers. 

 In the Position box, specify whether to place page numbers at the top 

of pages (header) or at the bottom of the page [footer]. 

 In the Alignment box, specify whether to align page numbers to the 

left, center or right of page. 

 If you don’t want a number on the first page, clear the Show number 

on the first page, check box, and then click OK. 

Inserting footnotes and endnotes 

Footnotes and end notes are used in large documents to explain comment on 

or provide references in a text or document. 

Footnotes appear at the bottom of the page while the endnotes appear at the 

end of a section or document. To insert a footnote or endnote: 

 On the Insert menu, point to Reference and then click Footnote or 

Endnote. 

 In the location section, click Footnote or End note and specify the 

location of footnote or end note. 

 In the Format section specify the number type start and continuity. 

 Click Insert. 

Using styles list. 

 

Styles’ list is predefined as set of formats that can be applied to a block of 

text together at once. To create a style: 

 

 Highlight the text you want to use to create a style. 

 Apply various formats to the text. 

 Click the Style box in formatting bar and type a name for the style. 

 Press enter key to apply the style name. 

Note: You can apply an existing style e.g. Headline 1, to highlighted text. 

 

Generating a table of contents and indexes  

A table of contents [TOC] a list of topics in a document and the page they 

appear. It is placed in the first page of the document. 
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On the other hand an index is a list of terms used in a document and the page 

they appear. 

It is placed in the back pages. In order to generate a [TOC], you must first 

mark entries by defining styles. 

To generate a table of contents, 

 Turn to the page you want to insert the table of contents. 

 On Insert menu, point to Reference, and then click Index and Tables. 

 Click the Tables of Contents tab. 

 Set the TOC properties and then click OK. 

 

CCrreeaattiinngg  aanndd  mmaanniippuullaattiinngg  aa  ttaabbllee    

A table is made up of rows and columns of cells. It is used to organize and 

present information. 

  

CCrreeaattiinngg  ttaabbllee..    

To create a table, 

 Click where you want to insert a table. 

 On the Table menu, point to Insert and then click Table. 

 In the Insert table dialogue box, set the number of columns and 

rows. 

 Specify an autoformat option if need be. 

NB: You can insert the table by clicking the table button on the standards 

toolbar, and then drag to select the number of rows and columns. 

 

To create a table using the drawing tool:  

 Click Tables menu, then Draw tables or simply click the Draw table 

button from the standards toolbar. The mouse pointer changes to a 

pencil symbol. 

 Drag the pointer to draw the outline of the table. 

 Fill in the table with rows and columns by dragging the pointer as you 

would using an ordinary pencil   

Inserting and deleting rows and columns                         

To insert arrow: 

 Place the curser where you want to insert a row. 

 Click Table, point to Insert, and then click Row above or Row below. 

To insert a column: 

 Place the cursor where you want to insert a column. 

 Click Table, point to Insert, and then click column to left or column to 

right. 
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To adjust column width: 

 Position the mouse pointer on the row or column boundary until the 

mouse pointer changes to an arrowed cross. 

 Drag the boundary to the required size. 

 

To delete rows columns of cells: 

 Select the rows or cells to be deleted 

 On Table menu, point to Delete, then click Columns, Rows or Cells 

Merging cells in a table 

This refers to combining more than one cell in a table. To merge cells: 

 Select the cells to be merged 

 On Table menu, click Merge cells. 

Splitting cells in a table.      

This refers to subdividing a cell or cells into more cells. To split cells: 

 Select cells to be split. 

 On the Table menu, click Split cells. A dialogue box appears where 

you specify the number of rows and columns and the selected cells 

will be split. 

Converting a table to text 

 Select the entire table or row and columns you want to convert to text 

 On Table menu, point to Convert, then click Table to Text. A dialog 

box is displayed that requires you to specify how the text will be 

separated after conversion 

 In the Separate text with box, enter or select the character to be used 

as a separator 

 Click OK 

Converting text to a table 

 Select the text that you want to convert to a table 

 On Table menu, point to Convert, then click Text to Table. A dialog 

box is displayed that requires you to specify the number of rows and 

columns 

 From Separate text at, specify whether the table will be defined by 

paragraphs, commas, tabs or other characters. 

 Click OK 

 

 

Word Arts 

Word arts are styles of writing on the computer from which you can choose 

on and use it in your document. They are commonly used in letter headings 

Inserting word art 

 Click on the Insert Word Art icon on the drawing tool bar 
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 In the Insert Word Art dialog box displayed, click on the style of 

Word art you want and then click OK 

 Type the text you want and click OK 

Clip Art 

These are already made pictures in the computer from which you can choose 

one and insert it into your document. 

Inserting Clip art 

 Click on Insert menu 

 Move to Picture 

 Click on Clip Art in the insert clip art window 

 Enter the category where you want to choose a picture from 

 Click on the picture you want 

 Click on Insert button 

 Finally close the insert Clip art box 

Cropping the picture 

Cropping simply means chopping off some parts or portions of the picture. 

To do this; 

 Click on the picture to make it active 

 Click on crop icon on picture toolbar and with the cropping tool, click 

on anyone mark 

 Display the side you want to crop off 

 Click and drag up to where you want to stop 

Keeping the picture behind the text 

 

 Click on the picture to make it active 

 Click on text wrapping icon 

 Choose a command ca 

Mail merge 

Mail merging is the combining of two  files (documents) into a single one. It 

is the mass production of letters. 

It can also refer to the process of generating personalized letters, labels or 

envelopes. 

There are 3 main tasks when creating a merged document. These are; 

1. Create a main document e.g. formal letter 

2. Create or get data source i.e. the address book 

3. Merge the two files to a new document, printer or email 

Steps when using mail merge 

 Create the main document 

 Click on Tools menu 

 Point to Letters and Mailings and then click Mail merge. A mail 

merge task pane is displayed. 
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 Select letters i.e. document type and then click Next arrow at the 

bottom of the task pane 

 Select the starting document in this case the Current document 

 Select recipients, in this case click Type a new list and choose create. 

After typing the details of the first recipient, continue until you finish 

all the required recipients 

 In case the item isn’t on the list, click Customize and choose add to 

add it on the list 

 After typing all the recipients close and save them under a file name 

 The Mail merge toolbar appears below the standard toolbar, click 

where you want to place the merge fields in your document e.g. 

<<first name>>  

 Click Insert Merge field on the mail merge toolbar then choose merge 

to new document and choose all 

 Scroll down to view all the letters 

 

Printing 

It is process of transferring a soft copy into a hard copy 

 Steps taken to print a document 

 Click on the File menu 

 Select Print. A print dialog box is displayed 

 Select the number of copies you want to print 

 Select the type of paper orientation e.g. portrait or landscape 

 Click on print preview before printing and if you are satisfied with the 

print preview, click OK to start printing 

NOTE: 

Creating a document involves entering text or numbers, inserting graphics 

and performing other tasks using an input device such as a keyboard or a 

mouse.  

Editing is the process of making changes to the existing content of the 

document. Common editing features include:  

  Inserting  

 Deleting  

 Cutting, copying, pasting e.t.c..  

Formatting involves changing the appearance of a document. Different 

levels of formatting include; character formatting, paragraph formatting, 

section formatting, document formatting e.t.c.  

Undo allows actions that have been performed to be reversed such that if 

some text was accidentally deleted, then the action can be undone.  

Saving is the process of copying a document from the memory to storage 

medium such as the floppy disk or hard disk. Any document that has been 
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saved exists as a file which is a name collection of data, instructions or 

information. Each file has a file name.  

Printing is the process of sending a file to a printer to generate output on a 

medium such a s a paper. A user can choose to print a document either in 

portrait (vertical) or landscape (horizontal) orientation A4 is the most 

popular sized paper used in Uganda. 

Text box: A text box is a four sided graphical figure that enables text to be 

typed within its boarders. 

Character map: This is a group of symbols that are not found on the 

keyboard 

Page break: This is a parameter that controls the number of lines to a page 

after which additional text will be placed onto the next page 

 

 

 

 

 

 

GOD BLESS YOU AS YOU 

REVISE!!!! 
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ELECTRONIC PRESENTATIONS. 

An Electronic presentation is a software application that is widely used to enhance the communication 

process with the use of visual aids like Presentation slides /slide shows. 

A presentation program is a computer software package used to display information  normally in form of 

a slide show. 

A presentation is a collection of slides relating to a specific topic that is to be delivered to a specific 

audience. 

Examples of presentation programs include: 

Microsoft PowerPoint, Lotus Freelance , Corel Presentation, Harvard graphics, Open Office.org Impress, 

Apple keynote, Magic point, K Presenter e.t.c 

Advantages of Presentation software  

 Presentation software usually provides a wide variety of presentation formats and lay outs for the 

slides.  

 Multimedia components such as slip art images, video clips and audio clips can be incorporated 

into the slides.  

 The timing of slides can be set so that the presentation automatically displays the next slide after 

a predetermined period of time.  

 Special transition effects can be applied between each slide.  

 The presentation can normally be viewed and printed in different formats e.g outline format, 

audience handout format and notes page format.  

 

Common types of presentations 

Informative presentation: This helps in informing your audience of certain affairs 

Analyzing presentation: This helps stake holders to analyze certain issues and device a way forward 

Persuasive Presentation: It is used to convince your listeners to accept your proposal. 

Instructional Presentation: It is used to give specific directions and orders 

Areas of application of Presentation include; 

 Advertising and marketing 

 Education /learning 

 New presentation 

 Corporate training sessions 

 Kiosks and multimedia 

Terminologies used. 

Slide: This is the working area or a single page of a presentation 

Title slide: This is the first slide in the order of slides normally with a heading and Sub heading. 
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Master slide/Slide master: This is a parent slide that contains text and objects that will appear on all 

other slides   .It helps in the editing/ formatting of other slides. 

Transition: A visual movement as one slide changes to another 

Template: This is the pre-designed slide styles or layouts that can be applied to a presentation to give a 

fully designed professional look. 

Animation and Animation schemes: These are visual effects applied to individual items on the slide. 

They can be applied on graphical images, titles or bulleted points. This allows your text and or graphics to 

appear on the slide from different directions and in various ways. 

Presenter/speaker: This is an individual who delivers the presentation to the audience 

Audience: This is a group of people who are interested in the presentation and are willing to listen to the 

presenter. 

Slide view: This refers to having a look at your slides and their contents. It is useful for organizing your 

text and graphics on the given slide. 

Slide show: This refers to the display of a slide and its contents which takes up the full computer screen. 

Normal view: This is main working window in the presentation and the slide is shown fully on the 

screen.  

Slide layout/slide types: This refers to the way how a slide and its contents are arranged or can be 

displayed. 

Slide sorter view: This gives you a view of all your slides at one go. It is good for arranging and 

organizing your slides. 

Text placeholder: An object on the slide usually a box that reserves a place for text 

Graphics placeholder: This is a space reserved on a slide usually a box for inserting graphics like clipart.  

Features of presentation software and their uses. 

 Insert slid feature: This allows you to insert slides anywhere in the presentation, at the 

beginning, middle or end. 

 Deletion of inserted slides: This allows you to remove any slide of the presentation. 

 Cut and paste slides: This allows you to move slides and their content from one position to 

another. 

 Animations and or sound manipulations on objects in the slide 

 View slide show feature: This allow you to display the presentation designed in a slide show 

system. 

 Transitions 

 Slides 

 Clip art and graphics 

 Font specifications: Allows you to change and use different font faces, styles and effects. 

 Layout management system: Presets or customizes layout designing 

 Spell checker and dictionary support 

 Macros: To add interactive features. 
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Principles of a good presentation. 

 Establish a uniform or single look for the presentation 

 Limit the number of slides 

 A good title slide attracts an audience attention. 

 Use contrasting colors for text and background so that the text is not fused into the background. 

 Include only one main concept and  not more than 25-30 words per slide 

 Avoid fancy fonts 

 Avoid script fonts 

 Avoid a lot of graphics and excessive use of slide transitions and animations 

 Keep animations consistent in the presentation 

 Use charts, slide graphics and diagrams where applicable.  

 Text and images should be kept within a reasonable distance from the edges of the slide 

Launching/Startup of Microsoft PowerPoint 

 Click on Start button 

 Select all programs 

 Click on Microsoft Office 

 Select Microsoft PowerPoint 2003 or 2007 options 

Saving a presentation 

 Click File menu 

 Click Save As 

 Select the location e.g. Desktop 

 Type the Filename in the filename box. 

 Click Save. 

Entering data in a slide 

 Click on Insert Menu 

 Select new slide 

 A new slide dialog box appears with a lot auto layouts. 

 Select a suitable slide of your choice e.g. bullet list option. 

 Click Ok 

 From Click add text, Type the title of the slide 

 And on the other Click to add text the sub title. 

Adding slides to a presentation 

 Click on Insert Menu 

 Choose new slide 

 Choose the slide layout of your choice. 

 Then Click Ok to complete 

Alternatively press Ctrl + M on the keyboard. 

Deleting Slides 

 Select the slide you want to delete 

 Click on the delete option 
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 Click Ok to confirm 

Creating slide master 

 With power point running, choose Slide master from the view menu 

 Start by formatting the master title slide. Click on insert layout in the insert slide menu option 

 Edit the theme (Colour, Font and Effects) of the master slide including the background styles 

This formatting will be the same on each new slide Title Area 

To observe this: 

 Click on new option from the office button or click Ctrl + N 

 Choose a slide that contains the title area 

 Click on the title area and start typing some text. The text format should duplicate that of the slide 

master 

Editing and formatting a presentation 

Applying slide transition 

 Click on Slide design 

 Select transition 

 Move your mouse to a slide of you want to apply transition effects 

 Click once to select 

 Click on Slide transition dropdown menu. 

 Choose the transition of your choice. 

Note: The preview is immediately applied on the selected slide. 

Applying reset animation style 

 Select the slide that contains the object to animate. 

 Click on slide show 

 Select reset animation option 

 Click on a suitable animation style to apply 

 Repeat step 1 to 4 to complete animating all the objects on the slide. 

Applying a design 

 Select the slide 

 Click on Format menu 

 Select Apply design template 

 Choose the design of your choice 

 Click on Apply 

Changing the background color 

 Select the slide 

 Click on the format menu 

 Select background 

 Click on the downward arrow besides the present color in the background and click on the color 

of your choice. 
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Adding a picture on the slide 

 Select the slide 

 Click on the insert clip icon on the drawing tool bar. 

Or 

 Click on Insert menu 

 Move to picture  

 Click on Clip art. In the Clip art dialog box, click on the category where you want to choose the 

picture from. 

 Click on the picture of your choice and click in insert clip button. 

 Finally close the clip art dialog box 

Creating a table 

 Click on insert menu 

 Select new slide command 

 Choose the slide layout called Table 

 Click on Ok 

 Double click to add the table 

 Select the number of rows and columns you want. 

 Click on Ok 

 Enter the information in the table. 

Creating charts 

 Click in the Insert menu 

 Select new slide command 

 Select the slide layout called Charts 

 Click Ok 

 Delete the information in the data sheet window ant type in your own information. 

 Close the data sheet window 

 Click to add the title of your chart 

Note: After the chart has been created, you can change it to another chart type you want e.g. pie-chart, bar 

graph, line graph e.t.c. 

Adding action buttons 

Action buttons enable you to link the slides. 

Steps taken 

 Select the slide 

 Click on the Slide show menu 

 Move to action buttons 

 Click on the type of action button you want 

 With the selected buttons, move to the slide where you want the button. 

 Then click and drag to draw a desired shape. 

 Choose the slide you want to be linked with current slide. 

 Click Ok. 
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Adding slide numbers 

 Click on the view menu 

 Select header and footer command 

 Put a tick on slide number 

 Click Ok. 

Note: In the same way of adding slide numbers, current date and time and footer can be added. 

Printing presentation 

 On the File menu, click print 

 In the print what option, select where you want to print like just the slides, notice or handout. 

 The handout option prints multiple slides per page. 

Note:  

 Inserting organizational charts 

 Creating a chart from data within slide presentation 

 Chart types include; Bar graph (Horizontal and Vertical), Line & Area graphs, Pie charts, Scatter 

charts, Special charts (Bubbles, Radar) e.t.c 

 The outline pane, Slide pane, Notes pane (view) 

 

 

 

“END” 
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TOPIC 9: ELECTRONIC SPREAD SHEETS 

 

Spread sheet software. 

Spread sheet software is used to organize data in rows and columns and performs calculation on 

the data.   

 

Microsoft Excel 

This is a full-featured spreadsheet program that allows you to organize data, complete 

calculations, make decisions, graph data, and develop professional looking reports. 

 

Terms used in spread sheet. 

• The worksheet is a grid of columns (indicated by letters) and rows (indicated by 

numbers). 

• A workbook- is a collection of worksheets. 

• The letters and numbers of the columns and rows (called labels) are displayed in gray 

buttons across the top and left side of the worksheet. 

• A row- is the horizontal arrangement of cells from the left to the right of the worksheet. 

• A column –is the vertical arrangement of cells from top to bottom.  

• A cell is an intersection of a column and a row.  

• Labels are text that identify the data and help organize the worksheet.  

• Values are numbers to be used for calculations. 

• Relative referencing-This changes when a formula is copied to another cell. 

• Absolute referencing-The values/formulae remain constant no matter where they are 

copied. 

 

 

Steps followed to open a Microsoft Excel program. 

a) Start button, All Programs, Microsoft office, Ms Excel. 

b) Microsoft Excel (using a short cut on the desktop). 

c) Start, run, type excel, ok. 

 

List the examples of popular spreadsheet software programs 

 Microsoft Office Excel 

 Lotus 1-2-3 

 Lotus Symphony 

 OpenOffice 

 VisiCalc 

 OpenOffice. 

 Ability Office 

 Apple works 

 EasyOffice 

 WordPerfect Office Quattro Pro 

 Framework 

 Kinggsoft Office 

 Lotus SmartSuite Lotus 123 

 MarinerPak Mariner Calc 

 Star office 

 PlanMaker 

 

 

 

 

Advantages of using an electronic spread sheet program over a manually generated spread 

sheet.                                               
 It has a bigger workspace compared to manual spread sheets. 

 It enables for auto update whenever data is entered and corrections made. 
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 It has provides the ability to work with in depth analysis through use of charts and 

multiple colours. 

 Produces accurate results since it uses embedded formulae that simplify work. 

 Enables users to work on the same worksheet from remote computers. 

 Work produced is clean and pleasant to look at. 

 It requires a small space to store an electronic spread sheet. 

 Information on charts can be updated automatically it is entered and modified. 

 

Disadvantages of using spread sheet software 

 They are susceptible to trivial human errors. 

 Data accuracy is difficult 

 Consumes a lot of time in validating and tracking data 

 It can be extremely challenging to spot and correct errors especially with larger volumes 

of data. 

 Keeping your spread sheet updated is also a hassle 

 Limited user access 

 It is ugly and boring 

 

 

Revision Questions. 
 

 

1. (a). Write any two ways you can express  =MAX(B4:B20)       (02 marks) 

 

=MAXA(B4:B20) 

=LARGE(B4:B20,1) 

 

(b). Describe how a shop keeper can use a spreadsheet program.     (03 marks) 

 

 A B C 

1 Item Quantity Unit price 

2 Sugar 20 3,500 

3 Salt 36 500 

4 Soda 65 800 

5 Rwenzori 98 2,000 

6 Yoghurt 56 3,000 

7 Toilet paper 23 1,000 

 

Note: Accept any description in statement form 

 

2. (a). Briefly, explain when the following functions can be used: 

 

(i). IF.           (01 mark) 

 

The IF function in Excel returns one value if a condition is true and another value if it's 

false. 
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(ii). COUNTIF                (01 mark) 

 

The COUNTIF function in Excel counts the number of cells that meet criteria you specify. 

 

(b) How many cells are in the range B10:G14?           (01 mark) 

 

30 cells 

 

(c). State any two qualities of a good graph.          (02 marks) 

 

 It should have a good descriptive title. 

 Should have right data selection. 

 Should be the right chart type. 

 18. (a).        Give the difference between a workbook and a worksheet. (01 mark) 
  
  

 A work book is a collection of work sheet in a spreadsheet application program, 

while; 

 a worksheet is a single work space in a spreadsheet. 
  
  

 (b).         State any two data types stored in a spread sheet 

  Labels. 

  Numbers. 

  Formulae. 
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ELECTRONIC DATABASE 

 

A data base is the collection of interrelated data about a particular subject or 

for a specific purpose that is organized or structured so that it can easily be 

accessed, analyzed, managed and up dated. 

 

DATABASE MANAGEMENT SYSTEM/SOFTWARE (DBMS) 

A database management system software is a collection of programs that 

enables users to create, access and manage databases 

 

Examples of Database Management Systems/software (DBMS)  

 Microsoft access 

 Corel paradox 

 Oracle 

 File maker Pro 

 Visual basic 

 Microsoft SQL 

 My SQL 

 Fox pro 

 Dbase V 

 Lotus approach 

Database components (Features of DBMS). 

Most DBMS software contain four major features that a typical database must 

consist of: - Tables (files), Queries, Reports, Forums. 

1. A table: This is a group of related data organized in fields (columns) 

and records (rows) on a datasheet. 

A field: Is the collection of data in a column form. It is a column on a data 

sheet and defines a data type for a set of values in a table. 

      A record: A record refers to the collection of the data in a row. 

2. Form: Is an object that allows you to enter and display (view) records 

from the database tables easily. Forms look exactly like the local forms 

on paper e.g. a receipt, registration form e.t.c. 

3. Query: Is a request of a given data in a table. Queries are data base 

objects that allow us to request for a given data stored in tables. 

4. Report: Reports enable one to preview and print data in a meaningful 

format. Examples of reports include lists, invoices, form letters, mailing 

labels e.t.c. 

5. Security utilities i.e only authorized users can access the database 

6. Backing up and restoring data 
7. Ability to update the data 

Other terms used in databases 
1. An object: This is a compilation in a database such as  a table, query, 

form or macro 

2. A file: This a combination of related records e.g. S.6 Subsidiary ICT 

group file 

3. Relation: It is the connection between two tables 

4. Data type: This is the kind of data for each field e.g. text , numbers, 

currency, e.t.c. 

5. Primary key: It is the field or combination of fileds that uniquely 

identifies each row in a table. 
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6. Foreign key: Is a field that is used to connect a relation ship between 

two tables. It is a copy of the primary key in another table. 

7. Candidate key: Is a field that uniquely identifies a record in more 

fields of a table. 

8. Composite key: This is a primary key that is comprised of two or more 

fields. It can also be called a Compound or Concanated key 

Note: 

SQL (Structured Query Language): Is a programming language used to 

create and manuplate databases. 

 

Components of database management system environment 

 Hardware: This ranges from a PC to a network of computers 

 Software: This includes DBMS (Oracle, Ms Access, and Visual basic), 

operating system, network software and application programs 

 Data: These are raw facts used by an organization and a description of 

this data is called the schema 

 Procedures: These are instructions and rules that should be applied to 

the design and use of the databases and DBMS 

 Users: These are the people who use the DBMS such as database 

administrators, programmers, end users e.t.c 

Functions of database management system/software 

 It provides an interface for a user to enter data 

 It helps organize data in a way that allows fast and easy access to the 

data 

 It enables you create, modify, store and retrieve data in a variety of 

ways 

 It enables users to create forms for input and display of data in a variety 

of ways 

 It enables users to filter out (query) records meeting given criteria 

 It enables the creation of summary reports 

TYPES OF DATABASES 

There are mainly two types of databases; Manual databases and Electronic 

databases. 

However, Electronic databases are today commonly used. 

Electronic databases are further categorizes into two—Distributed database 

(These sit on 

Individual stand –alone computers) and centralized databases (these sit on a 

database server). 

 

Advantages of using Electronic databases 

 Shared access: Collection of data stored and maintained at one central 

location to which many people access as needed. 

 It minimizes data redundancy. Individual users don’t have to collect 

and maintain their own sets of data. 
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 It ensures data consistency i.e. change to a data value affects all uses of 

the data value. 

 Data integrity: Data values are protected against accidental or malicious 

incorrect changes 

 It ensures controlled access: Only authorized users are allowed to view 

or modify data values 

 Database can store very large amounts of information 

 It is easy to bring related data together 

 Provides backup and recovery: a DBMS provides facilities for recovery 

from hardware and software failures. 

Disadvantages of using Electronic database  

 Lack of confidentiality, privacy and security. When information is 

centralized and is made available to users from remote locations, the 

possibilities of abuse are often more. 

 Data quality may be compromised. Since the database is accessible to 

users remotely, adequate controls are needed to control users updating 

data and to control data quality. 

 There is a threat to data integrity. The main threat of data integrity 

comes from several users attempting to update the same data at the 

same time. 

 Complexity. Database systems include sophisticated software packages 

that may require special hardware. They are difficult and time 

consuming to develop 

 Data can be pirated or corrupted by unscrupulous data managers. 

 Require highly-trained expertise for maximum management. 

 It is costly in maintenance. A complex database system requires regular 

maintenance especially of application programs and implementing of 

new applications such as software. 

Manual databases are non-computerized. These are traditional ways of 

recording and keeping data using simple devices e.g. a book with a list of 

items in stock, a diary e.t.c. 

However, these methods/databases (manual) had /have problems/weaknesses. 

 Poor update of records 

 Time wasting (when searching for particular item). 

 Unnecessary duplication of data 

 Misleading reports due to poor entry and organization. 

 

APPLICATIONS OF DATABASES 

 

 Computerized library systems 

 Student registration system 

 Flight reservation systems 

 Automated teller machines 

 Inventory systems 
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 Phone inquiry system  

 

 

DATA BASE MODELS 

A data base model is a structure of a format of a database. It is the way data 

can be organized, stored and manipulated. There are five types of data base 

model namely; 

 Relational database model: Here data is organized in form of 

rows and columns or tabular format. 

 Flat file model: This is a database model which when not being 

used, is stored on its host computer system as an ordinary file. 

 Network model: This is where data relationships, items and the 

database itself link to each other in form of a network. 

 Hierarchical data base model: In this model data is organized 

into a tree-like structure. 

 Object oriented model: In this model records in the database 

appear as independent objects which can relate with each other. 

 

INTRODUCTION TO MICROSOFT ACCESS 

Ms Access is application software used to organize or structure data in a 

tabular form so that it can easily be accessed, analyzed, updated and managed. 

How to create a database in Microsoft Access 

 Click on start 

 Select all programs 

 Click on Ms Office 

 Click on Ms Access 

How to save databases 

 From the save as dialog box displayed, select the folder where you are 

going to save your database 

 Type the filename of your database 

 Click on create button 

 And then a new database is created 

 

DATABASE OBJECTS 

These are the tools or applications that enable the user to create and manage 

his data in a data base. 

They include; 

 Tables 

 Queries 

 Forms 

 Reports e.t.c. 

CREATING TABLES 

A table is a collection of data about a specific topic or a particular subject. 
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Tables organize data into columns called fields and rows called records 

 

Each field contains a piece of information about the subject e.g. name and 

each record contains all the information about the field 

 

HOW TO CREATE TABLES 

Tables can be created in two ways i.e. using a wizard and design view 

Creating a table using a wizard 

 From the objects dialog box, click on tables 

 Select create table using the wizard 

 Click on the arrow to add the fields you want 

 Keep on selecting the appropriate option until you finish all the needed 

steps and finally click on Finish button 

Creating a table in the design view 

 This allows you to create the table manually 

 Start by clicking on the table under the object list 

 Double click to create table in design view 

 A new table is opened and displayed where you are supposed to insert 

the fields and the data type 

 And finally enter the records in the table 

DEFINING TABLE FIELDS 

A field is minimum unit of information e.g. the ID number, company name. 

A field name describes a type of information in each column. Each item of 

information entered into column is called a field value  

 

SELECTING THE DATA TYPES 

A data type simply refers to the characteristics of the field that determines 

what type of data that it can hold. 

 

Data type of field helps to determine or select the type of information you can 

store in the field and how access can work with that information. 

 

EXAMPLES OF DATA TYPES 

Text: This is a general purpose data type. It can contain letters, numbers and 

other characters such as %, $. The maximum is 255 characters per field 

record. 

Memo. It is a short form of memorandum. This type of data type is similar to 

text except that it is used for lengthy numbers and text such as comments or 

explanations. The size limit is 65535 characters 

Numbers: These are numerical data values that can be assigned to various 

field sizes. 

They are used for data to be included in the mathematical calculations except 

calculations involving money (for money values, we use currency type). 

Data or time. Value for data and time or both. It stores 8 bytes. 
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Currency: This type is used for currency values and prevents rounding off 

during calculations. Currency data typically has manual formatting 

Auto number: This type is used for unique sequential or random number that 

is automatically inserted when a new record is added in a field. 

It can be used as a primary key field for tables in which none of the fields 

have a unique settled value. 

Field values with auto number data type cannot be updated 

Yes/No (Boolean). It is used for data that can be only one of two possible 

values such as yes or no, true or false, NUL values (zeros) are not allowed  

OLE (Object Linking and Embedding). It is used for OLE  objects such as 

Microsoft excel, Ms word documents, pictures, sounds e.t.c. that are created 

in other programs using the OLE protocol. 

Hyper link. A hyperlink is a coloured and underlined text orographic that you 

click to go to a file allocation or a web page on the internet. 

A hyperlink can be a part on a URL. 

Look up wizard: It is used to create a field that allows you to look up a value 

in a different table or select one from the list. 

-When you to look up wizard, a look up wizard, a look up wizard dialogue 

box appear and select the option you will type in the values that you want.  

-Then click on the Text button  

-Type the values you want in the list one by one and after the last one, click 

on next button 

-State the level you would like for the look up column and then click on the 

Finish button. 

 

DESCRIPTIONS 

Field descriptions help you to describe the field. The field descriptions are 

optional i.e. you can either enter then or omit them. 

 

Setting field properties 

A property is a characteristic of an object such as its size, colour or format. 

Each field has a set of properties you use to specify how you want data to be 

stored, handled, and displayed. 

Field properties include field size, decimal places format, caption, default 

value, validation rule, and validation text.e.t.c.  

 

VALIDATION RULE 

It is an expression that limits the values that can be entered in the field. It 

defines data entry rules. It sets the expression that is added and evaluated 

when data in the field is added. 

To set the validation rule 

 Select the field whose property you want to set 

 Click in the validation rule box under Field properties 

 Type in the rule that defines property the property 
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 Then enter the validation rule and it works because validation rule goes 

hand in hand with validation text 

VALIDATION TEXT 

This is an error message that appears when you enter a value prohibited by 

the validation rule. It specifies the text of the message that appears if the field 

doesn’t satisfy the conditions listed in the validation rule settings. 

To set the validation text; 

 Click in the validation text box 

 Then in the string explaining validation rule, enter the expression 

NOTE:  

Validation This is the process of comparing the data entered with a set of 

predefined rules and values to check if data is acceptable. 

A validation is a mathematical expression where as validation text is a string  

 

SETTING A PRIMARY KEY 

A primary key is a field or combination of fields that uniquely identifies each 

record in a table i.e. distinguishes one record from another. The purpose of a 

primary key is to sort the record in a table.  

It allows access to quickly find retrieve, relate and associate records from 

multiple tables and bring the data together  

 

 

Qualities of a primary key 

 It doesn’t accept null (zero) values 

 It can’t allow duplication of data in that field 

To set a primary key; 

 Select the field you want to define as a primary key  

 Click on the primary key button on the standard tool bar  

Saving tables  

After defining the fields, you save the structure of a table 

To save; 

 Click on the File menu 

 Select save or press Ctrl+S on the key board  

 Type the name of the table and click on Ok 

 

Adding records to a table 

This is done in the database view  

To open the table in the data sheet view: 

 If you have the table opened in the design view, simply click on the 

view button on the table design view tool bar 

 If the table is closed, select the table by clicking on it 

 Then click on the open button in the database window 

Tables are organized in two records and fields; 
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A horizontal row in the table that corresponds to a record While A vertical 

column in the table that corresponds to a field 

A specific entry corresponding to the row and column in the table is known as 

a cell or a field value 

A field is a minimum unit of information or a category of information. Each 

field contains piece of information about the subject e.g. name 

A record is a collection of several field values or items put together. Each 

record contains all the information about the subject 

A table is a collection of the information about the specific topic or subject. 

 

Creating relationships between tables  
You create the relationship between tables so that you can combine the 

information from more than one table, queries, forms and reports. A 

relationship is formed by matching a common field in another table. The two 

valid types of relationships are One to one and One to many relationship 

Steps taken to create relationships 

 Click on the relationship icon on the tool bar 

 In the show table dialogue box, add the tables whose relationships you 

want to create  

 Select the table and click on the add button 

 After adding the table, close the show table window 

 In the relationships dialogue box, draft a common field and drop it in 

the similar field in another table 

 In the edit relationships dialogue box with two fields selected, click on 

the create button. 

 Save the relationships created by clicking on the save button 

 

USING QUERIES 

A query is the simply a question about the data in the database 

Queries are database objects that allows the user to view, change and arrange 

data stored in a table 

 

TYPES OF QUERIES 

1. Select queries: These are the queries that extract or show us data 

2. Action queries : These are the queries that carry out change to the 

records 

3. Crossed up queries:  These are used  to calculate and restrict data for 

easier analysis 

4. SQL queries (Structure query language):These are used  when we want 

some actions to be made on the data 

 

Creating queries  

You can create queries in two ways; 

 In the designed view  
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 Using a wizard 

Creating a query using a wizard. 

 Start by clicking a query tab under the object list 

 Double click create query using a wizard 

 Select the table and fields in the database that the query applies to. 

 The query wizard then builds the query for you based on your 

selections and run it to provide the results 

 Click on the next button and select relevant details 

 And then select next 

 Give the title to your query and finally click on the finish button 

Creating a query in the design view 

 Start by clicking on the query tab under the object list 

 Click on the new button on the database window 

 Select design view 

 Click ok 

 A list of all tables in the database are displayed in the show table 

dialogue box 

 Select the table that contains the information you want in the query by 

clicking on the table name and clicking on the add button or just double 

click the table name 

 Close the show table dialogue box by clicking on close button 

 The query window is displayed and it is divided into two sections i.e. 

the upper section displays a list of fields for the table added and the 

lower section is the query grid when you define the query and you will 

perform on the tables or select the information you want to retrive from 

the database  

This section has the following rows; 

 Field row which displays the name of the field added to the query 

 Table row which shows the name of the table where the field came 

from 

 Sort row which allows you to sort the information heading fields 

 Show row which determines what you want to be displayed in the 

query row 

 Criteria row which helps you set a criteria depending on the questions 

you want the query to answer  

 OR row which allows you to set a criteria having more than one 

condition 
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Tables of arithmetic operators and wild card symbols used in queries 

Operator Example Explanation 

> >500 Values over 500 

>= >=30 Values greater than and equal to 30 

< <16 Values less than or below 16 

<= <=30,000 Values less than and equal to30,000 

<> <>”KA” Not equal to (all cities besides 

Kampala) 

between Between 1 and 100 Numbers between 1 and 100 

 Is Null  

Is not Null 

Finds records with no values or all 

records that have a value 

 >0 And <=10 All numbers greater than0 and less 

than 10 

OR “Bob” or “John” Values are Bob or John 

 

Wild card 

symbol 

Explanation Example 

? Street The question mark is wild card 

that takes the place of a single 

letter 

Finds 1 street or 2 street 

“s*” All words beginning with s Like school, seal e.t.c 

43th*  The asterisk is the wild card 

that represents a number of 

characters 

 

*th 

 

*z 

The asterisk represents the 

wild card that ends in th 

All words ending with letter z 

18th  

M*NG Finds any record that starts 

with letter M ends with letter 

NG 

 

*ng* Finds records that has “ng” 

anywhere in the field 

 

4/*/2015 Finds all date in April 2015  

*/2015 Finds all dates in 2015  

 

Saving queries 

 Click on the Save button on the query designed tool bar and then type 

the query name and click Ok. 

 

Running the query 

This simply refers to opening the query in the query view to view the 

information. 

 To run a query click on the run button on the query design tool bar 
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Creating Forms 

A form is a database object which allows you to represent a data from a table 

graphically 

Forms can be created in two ways; 

 Using a wizard 

 Design view 

Creating a form using a wizard 

 Click on the form tab under the object list 

 Double click create a form using a wizard  

 Select the lay out of your forme.g. Columnar datasheet, tabular 

 Click on the next button 

 Choose the screen display and then click on the next button 

 State the title for your form 

 Select open the form to view ands enter the information  

 And click on the finish button 

 

Creating a form using a design view 

 Start by clicking on the form tab under the object list 

 Click on the new button and select design view to read or query 

 Choose the table or query where you want the object data to come from 

 Click on each field and drag it to the form until you finish all the 

required details 

 Click ok and save your form under a name 

Calculations in forms 

You can create a form that includes calculation such as total, averages 

 Open the form in design view 

 Click the text box tool on the tool box 

Do one of the following: 

 To calculate a total or average for a group of records, add the text box 

to the group header or footer 

 To calculate a grand total or average for all the records in a form, add 

the text box to the header or footer of the form 

 Select the text box and then click properties sheet on the tool bar 

 Click the data tab on the property sheet dialog box 

 Click the three dots next to control source 

 Insert the fields you wish t include in the calculation and the 

mathematical operations 

 Click ok 

 

Creating Reports 

 Reports are database objects used to present the data of a table or a query in 

order to print it. 
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Creating reports using a wizard 

 Start by clicking on the reports tab under the object list 

 Double click create report using wizard  

 Select the table or query where the objects data will come from 

 Select the fields you want by clicking the field name and clicking on 

the arrow key(s) (>or>>) 

 After selecting the field. Click on the next button 

 Select the sort order either ascending or descending 

 Choose the lay out of the report e.g. tabular, columnar 

 Choose the orientation you want for the report e.g. portrait and land 

scape 

 Click next 

 State the title you would like for your report 

 Choose whether you want to preview the report or modify reports as 

desired 

 Click on the finish button 

 

Creating a report in the design view 

 Start by clicking on the reports tab under the objects list 

 Click on the new button 

 Select the design view 

 Choose a table or query where data will come from 

 Click ok 

 And we add the fields to the report in the same journey (way) as you do 

to forms 

 After adding the fields to the report, save it and then close it 

 And to open the report, double click the report’s name 

 

Printing access objects 

 To print the entire copy of the object, all you have to do is to click on 

each object and open the object name and choose print from the file 

menu  

 

Querying is to use a specific set of rules (i.e criteria) for retrieving data from 

the database.  

Sorting is to organize a set of records in a particular order.  
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TOPIC 10: ELECTRONIC PUBLICATION 

Define the term Electronic Publishing 

E-Publishing refers to the use of digital resources and equipments to create and disseminate 

information by electronic means. 

Give three forms of Electronic Publishing 

 Web Publishing.. 

 Desktop publishing 

Distinguish between web publishing and desktop publishing. 

Web publishing (online publishing) which refers to putting content/ information to a website and 

the internet. While 

Desktop publishing: is the production and designing publications with advanced features and 

graphics by use of the computers. The publications include newsletters, business cards, 

brochures, invitation cards and like. 

Give the examples common desktop publishing software. 

 Microsoft Publisher Xara Page&Layout Designer 

 Adobe InDesign Xara Designer Pro X Ultra XML  Serif Ready Set, Go, 

 Adobe Illustrator 

 Adobe Page Maker 

 Akhar 2016 

 Calamus 

 Corel Draw 

 Corel Ventura 

 Flip B 

 In House Digital Publishing Software. 

 FrameMaker 

 HTML5 Page Flip 

 Hyphen 

 InPage 

 Maul Publisher 

 Page Plus 

 Page Stream 

 Prince XML 

 PUB HTML5 

 QuarkXPress 

 Quick silver 

 RagTime 
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State the areas of application areas/ uses of electronic publishing software. 

 Used in designing email publishing content. 

 Producing electronic books 

 Producing electronic journals 

 Used in web publishing 

 Developing digital content 

 

Identify advantages of electronic publishing. 

 It is speedy and easily searchable. 

 Rapid communication between the participants on the network. 

 Electronic interaction with the buyer or user of an e-publication where the producer can 

collect valuable market research data very cheaply. 

 Lower costs of review to changes and additions. 

 E-publishing is accessible to all users regardless of a geographical location. 

 Saves time and storage as more information can be stored electronically than on paper. 

Give the disadvantages of electronic publishing. 

 Web services may not get available everywhere.  

 Many people will need training to use the resource. 

 It requires computing equipment to use. 

 Web pages may experience inconsistency of appearance between different computer 

architecture.  

 Update is not of all pages. 

State the characteristics of Desktop Publishing Software. 

• They have colour libraries. 

• They have drawing and picture editing tools. 

• They allow for colour separation. 

• They do high quality graphics work. 

 

State the features of desktop publishing software. 

Page layout: The ability to define the layout of a page using frames to place text and pictures. 

Font and styles: A wide range of fonts and styles. 

Drawing facilities: Some drawing facilities, although they may be limited. 

Importing pictures and text: The ability to incorporate pictures and text from other packages 

into a document. 

Clip art: A library of pictures for you to include in your document 

Accurate positioning: The ability to position objects extremely accurately on the page using 

guidelines or a grid. 
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Name the documents that can be created using publication software 

 Business card  

 Certificates 

 Greeting cards 

 Invitation cards 

 Brochures 

 Flyers 

 Identity cards 

 Calendars 

 News letters 

 Envelopes  

Explain the common terms as used in desktop Publishing Software. 

Frame-This contains a variety of objects such as graphics, tables, text boxes which can be 

resized, moved and manipulated to suite the user needs. 

Handles-They enable you resize your frame by clicking and dragging around them. 

Template-These are pre-defined and pre-chosen design styles and formats that you can use. 
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0 (a) Definition of a motherboard: A piece of silicon or semiconducting material onto which 

integrated circuits or other electric components are embedded/printed/fixed. 

A circuit board found inside the system unit that holds a number of electronic components 

attached to the computer. 

(b) Identification of components housed on the motherboard. 

  Microprocessor 

  BIOS chip  

  Display adapters 

  Built in VGA 

  NIC 

  AGP and PCI expansion slots 

  Buses 

  CMOS battery 

  Heat sink 

  Transistors 

  Ports. 

11(a) Definition of terms as used in publications 

(i) Frame: A feature that enables a user to fit in the required text or image of the required 

dimension. 
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(ii)Template: A computer document containing basic information that is used as a model for 

writing other documents such as business letters, envelopes, etc. 

This is a tool having a pre-formatted design styles that can be used in publication to help a user 

easily create basic publication. 

(b) Listing desktop publication software 

 Adobe illustrator 

  Microsoft Office Publisher (Ms Publisher) 

  Adobe PageMaker 

  Print Master 

  PrintShop Professional 

  Siera Print Artist 

  Coral Draw 

  Adobe InDesign 

  Serif page plus 

(c) Naming a document that can be produced using publication software 

  Brochure 

  Cards 

  Certificates 

  Calendars 

  Posters 

  Flyers 

  Banners 

  Webpage 

  Newsletter 

 11.(a).         What is a desktop publishing?                                                        

(01 mark) 
  

  

 Is used to design and produce complicated documents that contain 

text, graphics, and brilliant colors. 
  

 (b).        State two features of desktop publishing application programs. 

 (02 marks) 
  

  

  DTP software is specifically designed to support page layout, 

which is the process of arranging text and graphics in a document on 

a page-by-page basis. 
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  DTP software includes color libraries to ensure that colors will print 

exactly as 

 specified. 

  DTP software supports colors separation for producing the 

master copies used in the final presswork. 
  

 (c).         Give two examples of desktop publishing application 

programs. 
 (02 marks) 

  Microsoft Publisher. 

  Adobe PageMaker. 

  Adobe InDesign. 

  QuarkXpress. 

  Broderbund Print Shop Pro. 
 


	WORD FULL
	POWERPOINT
	SPREADSHEETS
	DATA BASE COMPLETE
	PUBLICATIONS

